import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=/)([0-9]{1,2})[*]*([GM])[+]?(\\1[*]*\\2[+]?)+";
final String string = "AA/8G+8G+8G+8G/WITHOUT *\n"
+ "AA/8*G+8*G+8*G+8*G/WITH *\n"
+ "AA/8G+8*G+8*G+8*G/MIXED, THIS IS NOT SUPPORTED YET\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}