re = /(?<=\/)([0-9]{1,2})[*]*([GM])[+]?(\1[*]*\2[+]?)+/
str = 'AA/8G+8G+8G+8G/WITHOUT *
AA/8*G+8*G+8*G+8*G/WITH *
AA/8G+8*G+8*G+8*G/MIXED, THIS IS NOT SUPPORTED YET
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end