import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\{\\:,]([\\w\\s\\d]{2,})";
final String string = "[{isin: US51817R1068, name: LATAM Airlines Group SA}, {isin: CL0000000423, name: LATAM Airlines Group SA}, {isin: null, name: LATAM Airlines Group SA}, {isin: BRLATMBDR001, name: LATAM Airlines Group SA}]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}