const regex = /[\{\:,]([\w\s\d]{2,})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\{\\:,]([\\w\\s\\d]{2,})', 'g')
const str = `[{isin: US51817R1068, name: LATAM Airlines Group SA}, {isin: CL0000000423, name: LATAM Airlines Group SA}, {isin: null, name: LATAM Airlines Group SA}, {isin: BRLATMBDR001, name: LATAM Airlines Group SA}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}