$re = '/[\{\:,]([\w\s\d]{2,})/';
$str = '[{isin: US51817R1068, name: LATAM Airlines Group SA}, {isin: CL0000000423, name: LATAM Airlines Group SA}, {isin: null, name: LATAM Airlines Group SA}, {isin: BRLATMBDR001, name: LATAM Airlines Group SA}]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);