const regex = /^([5-9][0-9]|[1-9][0-9]{2,4}|100000)(\.\d{2})?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([5-9][0-9]|[1-9][0-9]{2,4}|100000)(\\.\\d{2})?$', '')
const str = `300`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}