import Foundation
let pattern = #"^([5-9][0-9]|[1-9][0-9]{2,4}|100000)(\.\d{2})?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"300"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}