$re = '/^([5-9][0-9]|[1-9][0-9]{2,4}|100000)(\.\d{2})?$/';
$str = '300';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);