const regex = /(?!aBc)[aA][bB][cC]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!aBc)[aA][bB][cC]', 'g')
const str = `This should match:
ABC
ABc
AbC
Abc
aBC
abC
abc
Text with abc in it should also match. Even if it is within a word like in Barabc Obama.
This must not match:
aBc
cba
aaa
bbb
ccc
bac
ABBA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}