import Foundation
let pattern = #"(?!aBc)[aA][bB][cC]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This should match:
ABC
ABc
AbC
Abc
aBC
abC
abc
Text with abc in it should also match. Even if it is within a word like in Barabc Obama.
This must not match:
aBc
cba
aaa
bbb
ccc
bac
ABBA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)