package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"access_token":"([^"]*)"`)
var str = `{"access_token":"xxxxxxxxxxxxxxxx","token_type":.......}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}