$re = '/"access_token":"([^"]*)"/m';
$str = '{"access_token":"xxxxxxxxxxxxxxxx","token_type":.......}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);