re = /"access_token":"([^"]*)"/m
str = '{"access_token":"xxxxxxxxxxxxxxxx","token_type":.......}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end