using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"u\'([^\']*)\'";
string input = @"{
u'state': u'CA',
u'page_size': u'1000',
u'market': u'Western',
u'requested_at': u'2014-10-28T00:00:00+00:00'
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}