package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`u\'([^\']*)\'`)
var str = `{
u'state': u'CA',
u'page_size': u'1000',
u'market': u'Western',
u'requested_at': u'2014-10-28T00:00:00+00:00'
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}