package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^-]*- (.+?)(?:THIS|$)`)
var str = `START - some words and not THIS
START - some words and not`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}