$re = '/[^-]*- (.+?)(?:THIS|$)/m';
$str = 'START - some words and not THIS
START - some words and not';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);