re = /[^-]*- (.+?)(?:THIS|$)/m
str = 'START - some words and not THIS
START - some words and not'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end