#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).* <(Begin|End)_Date[Tt]ime> .*RC (\d)"
Local $sString = "something something <Begin_DateTime> and then tehre is RC 0" & @CRLF & _
"something someting <End_Datetime> and then there is RC 1" & @CRLF & _
"" & @CRLF & _
"something something <Begin_DateTime> and then tehre is RC 1" & @CRLF & _
"something someting <End_Datetime> and then there is RC 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")