$re = '/.* <(Begin|End)_Date[Tt]ime> .*RC (\d)/m';
$str = 'something something <Begin_DateTime> and then tehre is RC 0
something someting <End_Datetime> and then there is RC 1
something something <Begin_DateTime> and then tehre is RC 1
something someting <End_Datetime> and then there is RC 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);