using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".* <(Begin|End)_Date[Tt]ime> .*RC (\d)";
string input = @"something something <Begin_DateTime> and then tehre is RC 0
something someting <End_Datetime> and then there is RC 1
something something <Begin_DateTime> and then tehre is RC 1
something someting <End_Datetime> and then there is RC 0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}