#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\s+(#[^\n]*\n)?)"
Local $sString = "some text" & @CRLF & _
"" & @CRLF & _
"E-mail Address: user123@gmail.com" & @CRLF & _
"Billing Address:" & @CRLF & _
"" & @CRLF & _
"Harry Smith" & @CRLF & _
"3423 My Lane" & @CRLF & _
"SOME CITY, CA 94105" & @CRLF & _
"United States" & @CRLF & _
"" & @CRLF & _
"I want to match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")