import Foundation
let pattern = ##"(\s+(#[^\n]*\n)?)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
some text
E-mail Address: user123@gmail.com
Billing Address:
Harry Smith
3423 My Lane
SOME CITY, CA 94105
United States
I want to match
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}