$re = '/([^0-9\n]+)[0-9]?.*/';
$str = 'abc123
#$%@#<>@<123
abc
abc @#@#@-122
a123b456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);