re = /([^0-9\n]+)[0-9]?.*/
str = 'abc123
#$%@#<>@<123
abc
abc @#@#@-122
a123b456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end