using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d*x\d*x(.*)\.pagespeed.*";
string substitution = @"$1";
string input = @"700x524ximagename700x524.jpg.pagespeed.ic.9rlwkDUtDK.webp";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}