re = /\d*x\d*x(.*)\.pagespeed.*/
str = '700x524ximagename700x524.jpg.pagespeed.ic.9rlwkDUtDK.webp'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result