const regex = /\d*x\d*x(.*)\.pagespeed.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d*x\\d*x(.*)\\.pagespeed.*', '')
const str = `700x524ximagename700x524.jpg.pagespeed.ic.9rlwkDUtDK.webp`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);