package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`return.*(\s+)?$`)
var str = `local function test()
print("Hello!")
end
return thing`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}