re = /return.*(\s+)?$/
str = 'local function test()
print("Hello!")
end
return thing'
# Print the match result
str.match(re) do |match|
puts match.to_s
end