#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[((\d+|"([^"]|\\")*?")\s*,?\s*)*(?<!,)\]"
Local $sString = "const arr = [123, "hjhehe", "lala"]" & @CRLF & _
"const arr = [123, "hjhehe", "lala",]" & @CRLF & _
"const arr = [123, "hjhehe, "lala"]" & @CRLF & _
"const arr = [123, "hjhe\"he", "lala"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")