using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[((\d+|""([^""]|\\"")*?"")\s*,?\s*)*(?<!,)\]";
string input = @"const arr = [123, ""hjhehe"", ""lala""]
const arr = [123, ""hjhehe"", ""lala"",]
const arr = [123, ""hjhehe, ""lala""]
const arr = [123, ""hjhe\""he"", ""lala""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}