$re = '/\[((\d+|"([^"]|\\\\")*?")\s*,?\s*)*(?<!,)\]/m';
$str = 'const arr = [123, "hjhehe", "lala"]
const arr = [123, "hjhehe", "lala",]
const arr = [123, "hjhehe, "lala"]
const arr = [123, "hjhe\\"he", "lala"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);