#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)COM\s([REV|LIB])"
Local $sString = "COM REV" & @CRLF & _
"COM EV" & @CRLF & _
"COM V" & @CRLF & _
"COM |" & @CRLF & _
"COM L" & @CRLF & _
"COM I" & @CRLF & _
"COM B"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")