package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)COM\s([REV|LIB])`)
var str = `COM REV
COM EV
COM V
COM |
COM L
COM I
COM B`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}