package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(1?\d|2[0-3]):[0-5]\d$`)
var str = `12:12
01:12
23:33
25:33`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}