$re = '/^(1?\d|2[0-3]):[0-5]\d$/m';
$str = '12:12
01:12
23:33
25:33';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);