import re
regex = re.compile(r"^(1?\d|2[0-3]):[0-5]\d$", flags=re.MULTILINE)
test_str = ("12:12\n"
"01:12\n"
"23:33\n"
"25:33")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")