using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\?@(.*?)\)";
string input = @"Apr 17 23:39:02 test pure-ftpd: (?@researchscan425.eecs.umich.edu) [INFO] New connection from researchscan425.eecs.umich.edu";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}