re = /\(\?@(.*?)\)/
str = 'Apr 17 23:39:02 test pure-ftpd: (?@researchscan425.eecs.umich.edu) [INFO] New connection from researchscan425.eecs.umich.edu'
# Print the match result
str.match(re) do |match|
puts match.to_s
end