package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(\?@(.*?)\)`)
var str = `Apr 17 23:39:02 test pure-ftpd: (?@researchscan425.eecs.umich.edu) [INFO] New connection from researchscan425.eecs.umich.edu`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}