#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<metric>.*)(?<fields>:{.*})? (?<value>.*)"
Local $sString = "jvm_buffer_memory_used_bytes{id="direct",} 81920.0" & @CRLF & _
"jvm_buffer_memory_used_bytes{id="mapped",} 0.0" & @CRLF & _
"jvm_threads_live 23.0" & @CRLF & _
"tomcat_global_received_bytes_total{name=" http - nio -8080",} 0.0" & @CRLF & _
"tomcat_global_received_bytes_total{name="http-nio-8080",} 0.0" & @CRLF & _
"jvm_gc_pause_seconds_count{action="end of minor GC",cause="Allocation Failure",} 7.0" & @CRLF & _
"jvm_gc_pause_seconds_sum{action="end of minor GC",cause="Allocation Failure",} 0.232" & @CRLF & _
"jvm_gc_pause_seconds_count{action="end of minor GC",cause="Metadata GC Threshold",} 1.0" & @CRLF & _
"jvm_gc_pause_seconds_sum{action="end of minor GC",cause="Metadata GC Threshold",} 0.01" & @CRLF & _
"jvm_gc_pause_seconds_count{action="end of major GC",cause="Metadata GC Threshold",} 1.0" & @CRLF & _
"jvm_gc_pause_seconds_sum{action="end of major GC",cause="Metadata GC Threshold",} 0.302" & @CRLF & _
"jvm_gc_pause_seconds_max{action="end of minor GC",cause="Allocation Failure",} 0.0" & @CRLF & _
"jvm_gc_pause_seconds_max{action="end of minor GC",cause="Metadata GC Threshold",} 0.0" & @CRLF & _
"jvm_gc_pause_seconds_max{action="end of major GC",cause="Metadata GC Threshold",} 0.0" & @CRLF & _
"jvm_gc_live_data_size_bytes 5.0657472E7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")