import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<metric>.*)(?<fields>:\\{.*\\})? (?<value>.*)";
final String string = "jvm_buffer_memory_used_bytes{id=\"direct\",} 81920.0\n"
+ "jvm_buffer_memory_used_bytes{id=\"mapped\",} 0.0\n"
+ "jvm_threads_live 23.0\n"
+ "tomcat_global_received_bytes_total{name=\" http - nio -8080\",} 0.0\n"
+ "tomcat_global_received_bytes_total{name=\"http-nio-8080\",} 0.0\n"
+ "jvm_gc_pause_seconds_count{action=\"end of minor GC\",cause=\"Allocation Failure\",} 7.0\n"
+ "jvm_gc_pause_seconds_sum{action=\"end of minor GC\",cause=\"Allocation Failure\",} 0.232\n"
+ "jvm_gc_pause_seconds_count{action=\"end of minor GC\",cause=\"Metadata GC Threshold\",} 1.0\n"
+ "jvm_gc_pause_seconds_sum{action=\"end of minor GC\",cause=\"Metadata GC Threshold\",} 0.01\n"
+ "jvm_gc_pause_seconds_count{action=\"end of major GC\",cause=\"Metadata GC Threshold\",} 1.0\n"
+ "jvm_gc_pause_seconds_sum{action=\"end of major GC\",cause=\"Metadata GC Threshold\",} 0.302\n"
+ "jvm_gc_pause_seconds_max{action=\"end of minor GC\",cause=\"Allocation Failure\",} 0.0\n"
+ "jvm_gc_pause_seconds_max{action=\"end of minor GC\",cause=\"Metadata GC Threshold\",} 0.0\n"
+ "jvm_gc_pause_seconds_max{action=\"end of major GC\",cause=\"Metadata GC Threshold\",} 0.0\n"
+ "jvm_gc_live_data_size_bytes 5.0657472E7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}