package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ims)^<(?:input).*?({{variable:system_version}}).*?>$`)
var str = `<input value="System version: {{variable:system_version}}">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}