$re = '/^<(?:input).*?({{variable:system_version}}).*?>$/ims';
$str = '<input value="System version: {{variable:system_version}}">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);