re = /^<(?:input).*?({{variable:system_version}}).*?>$/im
str = '<input value="System version: {{variable:system_version}}">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end