using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^GB(?:\d{3} ?\d{4} ?\d{2}(?:\d{3})?|[A-Z]{2}\d{3})$";
string input = @"GB999999973
GBGD001
GBHA599
GB999 9999 73";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}