re = /^GB(?:\d{3} ?\d{4} ?\d{2}(?:\d{3})?|[A-Z]{2}\d{3})$/m
str = 'GB999999973
GBGD001
GBHA599
GB999 9999 73'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end