package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^GB(?:\d{3} ?\d{4} ?\d{2}(?:\d{3})?|[A-Z]{2}\d{3})$`)
var str = `GB999999973
GBGD001
GBHA599
GB999 9999 73`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}