const regex = /(?<order>(\d+))\n(?<start>([\d:,]+))[\s-{2}\>]+(?<end>([\d:,]+))\n(?<text>(.+|\n))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<order>(\\d+))\\n(?<start>([\\d:,]+))[\\s-{2}\\>]+(?<end>([\\d:,]+))\\n(?<text>(.+|\\n))', 'gi')
const str = `1
00:01:35,418 --> 00:01:43,418
In 2015 an American archeological company
bought a military manuscript from the Han Dynasty
2
00:01:45,293 --> 00:01:49,501
It said
Roman soldiers went to China 2,000 years ago
3
00:01:49,918 --> 00:01:53,084
and the ancient city of Regum was bulit
4
00:01:53,918 --> 00:01:57,084
The archeological community believed
it was a fake`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}